FordFusionClub.com banner
1 - 15 of 15 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter · #1 ·
I have two Infinity amps about 15"w X 12"h and 2 1/2" tall. Any suggestions on where to mount these? I was told to use attach a board to the seat backs and install onto that board.... please e-mail me or respond to this message. Thank you.
 

·
Registered
Joined
·
221 Posts
try putting an amp on sub box. it is just an idea
 

·
Registered
Joined
·
1,632 Posts
I would push your sub box as far back as you could in the trunk and then build an amp rack or box for amps to sit in, and then plexy over it, so you can atleast put something back there...
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #4 ·
will I still have access to the spare if I do that? I don't have any rear speakers, what about mounting the inverted on the back dash? I've also though about building a rack, drop it down about 6" from the rear deck and I will still have room for the sub box and I'm not losing space. Thanks for your comment.
 

·
Registered
Joined
·
443 Posts
I made a rack out of mdf like you describe in your original post. You can see it at my cardomain page below. I still have access to my spare, and I can remove my sub box in less than 1 minute (it's attached to the chassis behind the back seat with 2 L brackets).
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #6 ·
where did you run the main power supply? through the place where the factory wires are ran through the firewall? Thanks for the assist!
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #8 ·
any problem getting the wire through the grommet? What size wire was your power supply? I am using 4 guage and it's very thick. Thanks again.
 

·
Registered
Joined
·
443 Posts
My original install was done at Tweeter and they found the grommet. They used 8ga wire and it fit with no problems. When I added my second amp, I did the re-wiring and went with 4ga. It's a little snug, but it will slide through. A little liquid soap will help if it sticks.
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #10 ·
do you have an automatic or standard? I have a standard. I took the battery out and everything, either I am looking in the wrong spot or you have an automatic... I think I am going to hook everything up and just pay circuit city to run the power cable. They will do it for like $50...unless you have other suggestions. thanks.
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #12 ·
they wanted to charge around $400 for everything...so I will probably install speakers, run wires, and build amp rack, and have them power it up. Thanks again.
 

·
Registered
Joined
·
22 Posts
Ran my own wires, pulled radio. Just could not do line converter..CC charged me 30 buck to do LC and make sure the amp ran...
 
1 - 15 of 15 Posts
Top