FordFusionClub.com banner

1 - 9 of 9 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter #1 (Edited by Moderator)
less than 2 months ago i bought a 2006 Milan. I'm getting horrible gas mileage and it doesn't seem to be shifting at the right times. others have recommended I reset the TCM but I'm not sure how. one person said just disconnect the battery and try to start the car to clear the current. after doing a little research I can't find anything online but most cars have some sequence of turning the key a couple times and switching back and forth from neutral to drive several times. can anybody tell me the proper way? thanks! your help is appreciated.

Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
58 Posts
Have you tried contacting A ford dealer? When I was test driving the fusion some of the vehicles where not reset and still on factory settings. The sales guy instructed me how to change the settings. I don't remember it now, but might be worth a phone call.
 

·
Registered
Joined
·
42 Posts
Discussion Starter #4
I don't like messing with the dealership. enthusiasts usually know a lot more about their cars. every dealership I've been to in my area is only worried about making a buck. the last time I did business with a dealer i paid them $80 to calibrate my speedometer after getting bigger tires on my truck. it took 2 minutes and they didn't even fix it. a week later I went to a different dealer 50 miles away and they did it correctly for free. that's only one of many stories lol.
 

·
Registered
Joined
·
42 Posts
Discussion Starter #5
Paul, I may be taking your advice soon enough. I've tried several things over last 5 tanks and nothing helps.

Things ive tried oe checked:
- tires are brand new and properly inflated
-baby the hell out of it. No WOT
- not using AC and sweat my ass off
-cruising 60-70 mph on hwy
-branded gas and unbranded gas w/ and w/o lucas.
- unplugged battery to reset TCM/ECU
- installed steeda cold air intake

I started tracking mpg on paper and over those last 5 tanks its almost exactly 19mpg. Car is driven about 35city/65hwy. any other ideas people?
 

·
Super Moderator
Joined
·
5,839 Posts
Paul, I may be taking your advice soon enough. I've tried several things over last 5 tanks and nothing helps.

Things ive tried oe checked:
- tires are brand new and properly inflated
-baby the hell out of it. No WOT
- not using AC and sweat my ass off
-cruising 60-70 mph on hwy
-branded gas and unbranded gas w/ and w/o lucas.
- unplugged battery to reset TCM/ECU
- installed steeda cold air intake

I started tracking mpg on paper and over those last 5 tanks its almost exactly 19mpg. Car is driven about 35city/65hwy. any other ideas people?
Hi drive. How many miles on vehicle? Ever had a full or partial tune-up performed before or after you purchased? Plugs, coils/wires, air cleaner etc.? When, what and how many miles ago? Oil changed recently? Brakes checked for a dragging caliper etc.? Transmission operating correctly and properly maintained/serviced? So many details unknown which could affect mpg's. And sometimes it is just better to take it to a trusted tech/mechanic and let them diagnose and repair the issues.

And as an FYI, a so-called "cold air intake" will do nothing for mpg's.

Provide more information and someone may be able to help.

Good luck.
 

·
Registered
Joined
·
42 Posts
Discussion Starter #7
Thanks for giving me a few more things to check. as far as the details you're talking about, I don't know much. I've only had it 2 months and have put less than 3000 miles on it. it currently has 93k mi. an oil change was done a few days before I bought it. at the time of purchase the rotors were practically new. the transmission doesn't shift like I would like it too. it likes to go up to 4K before shifting unless i take off really really slow. that's what I was trying to figure out how to reset the TCM. For the last 2wks on my days off I've tried taking it into my mechanic but he's been booked up. I was going to have him check the plugs and wires. I'm glad you mentioned the brake caliper thing. I'll have him check that too. I've noticed a low squeak a few times while driving slow near a wall.

thanks for your input!
 

·
Registered
Joined
·
1 Posts
Thanks for giving me a few more things to check. as far as the details you're talking about, I don't know much. I've only had it 2 months and have put less than 3000 miles on it. it currently has 93k mi. an oil change was done a few days before I bought it. at the time of purchase the rotors were practically new. the transmission doesn't shift like I would like it too. it likes to go up to 4K before shifting unless i take off really really slow. that's what I was trying to figure out how to reset the TCM. For the last 2wks on my days off I've tried taking it into my mechanic but he's been booked up. I was going to have him check the plugs and wires. I'm glad you mentioned the brake caliper thing. I'll have him check that too. I've noticed a low squeak a few times while driving slow near a wall.

thanks for your input!
I’m just now getting my fusion and joining the club, so yes it’s been some years but did you get this issue resolved??
 
1 - 9 of 9 Posts
Top