FordFusionClub.com banner

1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
2011 Ford Fusion 3.0 SEL

Started having issues with power locks. I’d would lock the door, then it would unlock by itself. Then issues with radio. It would not turn on, but the display would come on. While driving, The volume and tuner knobs would flash and the display would turn off and then back on with “Ford Fusion”. The turning signals seem to pause, or hesitate, mid use. While driving, the dash warning lights will come on and off randomly (check engine, ABS, ... probably others. Also while driving, the car will ding (I believe it is the sound the car makes when you put the key in, or turn it to on).

So it seems like something is loosing power sporadically. I am thinking a bad ground (at least one was visibly corroded and read that painted grounding surfaces from the factory can lead to issues) or possibly an issue with a body control module or something.

Tested battery and alternator and both came back good, but will often come out to a dead battery. The car does sit a lot, but it will be 100% dead- where the door won’t unlock without physically turning the key.

Been trying to find information about the modules in my car. What controls those functions? Is it the “multifunction control module”? Does my car have a “Body Control Module”?

If it is a control module of some sort, will it need to be purchased from Ford and reprogrammed by the dealership? I need to save as much money as possible. I’m not working much with social restrictions in place.

Dealership wants $145 per hour to look for the issue and says it might take 10 hours to look. I’m still waiting to hear back after the initial $145 (1 hour) diagnostic.

What should have been checked during that first 1 hour diagnostic so I know what to ask the service department?

Thanks in advance,
Bob

Also forgot to mention...
A while back, the driver side heated seat stopped heating. The light would come on, but it would turn off after a second.

And some DIY repairs that may have caused an issue...

Additionally, I replaced the rear plate lights (2 above the lic. Plate) with Cheap aftermarket LEDs when the original ones went out.

I replaced the horn with cheap aftermarket replacement when it failed.

The spark plug blew out and took an ignition coil with it. I replaced the plug, the coil, and spliced the wire myself. No issues immediately after the repair and it still drives great.
 
1 - 1 of 1 Posts
Top