FordFusionClub.com banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
So I've just been living with this for a few years but am wondering if anyone has any ideas?
My ac blows pretty dang weak at max and you cant even notice it at minimum speed, however it does blow cold.

In the past I've replaced the blower motor (didnt make a difference) and had to replace the evap temp sensor when it went kaputz. Its just that now it while it somewhat still cools you cant really feel it and on a hot day its pretty uncomfortable.

Will take any suggestions!
 

·
Super Moderator
Joined
·
5,981 Posts
So I've just been living with this for a few years but am wondering if anyone has any ideas?
My ac blows pretty dang weak at max and you cant even notice it at minimum speed, however it does blow cold.

In the past I've replaced the blower motor (didnt make a difference) and had to replace the evap temp sensor when it went kaputz. Its just that now it while it somewhat still cools you cant really feel it and on a hot day its pretty uncomfortable.

Will take any suggestions!
Hi belz. Could be any of multiple causes. A faulty switch, faulty resistor, faulty temp sensor, faulty blower motor (although you replaced it) etc

Unless you have the diagnostic tools to check and find the fault, you will simply be throwing parts at it. It may be best to take it to a shop that specializes in AC/climate control issues.

Perhaps one of our tech members will have more insight and jump in with some suggestions.

Let us know how you make out and good luck.
 
1 - 2 of 2 Posts
Top