FordFusionClub.com banner

1 - 3 of 3 Posts

·
Registered
Joined
·
145 Posts
Discussion Starter #1
OK need some help quick.
My brothers gotta opportunity to get a an 03' Sable with a twitch over 16k....but it has sat for couple of years.
new battery...turns over well....no fuel pressure....pulled off & replaced the fuel filter...& nothing coming out the hose.
The FP isn't activating....the fuses are good & relay is good...& yes added 5-6gal of gas.

the inertia switch is not tripped.....what else can we check
 

·
Registered
Joined
·
580 Posts
[quote author=enriched link=topic=192026.msg4046705#msg4046705 date=1307789696]
OK need some help quick.
My brothers gotta opportunity to get a an 03' Sable with a twitch over 16k....but it has sat for couple of years.
new battery...turns over well....no fuel pressure....pulled off & replaced the fuel filter...& nothing coming out the hose.
The FP isn't activating....the fuses are good & relay is good...& yes added 5-6gal of gas.

the inertia switch is not tripped.....what else can we check
[/quote]

If the car has set for a long time, the fuel pump may be locked up and you will need to replace it. The fuel turns to varnish after a long period of time. 16K on an 2003 Sable, wow!
 

·
Registered
Joined
·
145 Posts
Discussion Starter #3
well that is what he did...took it to his mechanic.
the FP was shot....drop and flushed the gas tank.
as well as 4 new tires, flush & changed the coolant and changed the oil and filter in both engine and tranny...thinking that he even put in a new T stat
 
1 - 3 of 3 Posts
Top