Mercury milan tailight problem - FordFusionClub.com : The #1 Ford Fusion Forum


FMVPerformance.com is the premier Ford Fusion Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools
Old 12-14-2012, 12:53 AM   #1
NYMERC
Bicycle Rider
 
Join Date: Sep 2012
Posts: 9
Default Mercury milan tailight problem

Greetings. I found this forum after an internet search for a tail light problem with a 2010 Mercury Milan.

Here is the issue:

If the parking lights or headlights are on the rear LED lamps (right side and left side modules) are illuminated in high intensity as if the brakes have been applied. If I apply the brakes there is no change in illumination as the lights are illuminated brightly as if the brake pedal is depressed even when the brake pedal is not applied. The third (high mount ) brake light functions normally and only illuminates when the break pedal is depressed.

If the lights are off (during daytime driving) and the brake pedal is applied then the brake lights function normally. Warranty is up in a few days. What can I do?
Thanks for any help.
NYMERC is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-14-2012, 01:11 AM   #2
bbf2530
Super Moderator
 
Join Date: Dec 2006
Posts: 5,613
Default

Quote:
Originally Posted by NYMERC View Post
Greetings. I found this forum after an internet search for a tail light problem with a 2010 Mercury Milan.

Here is the issue:

If the parking lights or headlights are on the rear LED lamps (right side and left side modules) are illuminated in high intensity as if the brakes have been applied. If I apply the brakes there is no change in illumination as the lights are illuminated brightly as if the brake pedal is depressed even when the brake pedal is not applied. The third (high mount ) brake light functions normally and only illuminates when the break pedal is depressed.

If the lights are off (during daytime driving) and the brake pedal is applied then the brake lights function normally. Warranty is up in a few days. What can I do?
Thanks for any help.
Hi NYMERC. What can you do? Since you only have a few days before your Warranty expires, you call to make a service appointment at your local Ford Dealer and stop wasting time looking for answers from people who can't diagnose or repair the issue.

It is not your job to tell the Service Department what is wrong, it is their job to diagnose and correct it.

Not trying to be a wise guy at all, but your time is limited so don't waste it.

Let us know how you make out and good luck.
bbf2530 is offline   Reply With Quote
Old 12-15-2012, 11:34 AM   #3
ahanix1989
Moderator
 
ahanix1989's Avatar
 
Join Date: Oct 2010
Location: Wisconsin, USA
Posts: 1,809
Send a message via ICQ to ahanix1989 Send a message via AIM to ahanix1989 Send a message via MSN to ahanix1989 Send a message via Yahoo to ahanix1989
Default

Get it into a dealer fast. Be very polite though, sometimes they will even do warranty work outside of warranty for safety issues like this, but only if they like you and you give them a reason to want to help.

Ford seems to have problems with LED taillights... I used to see a Montego on the highway all the time where using their turn signal would make all rear lights flash.

For curiosity's sake, if I had to guess as far as an actual cause, I'd say a short between the park and stop wires, or even a connector is reversed.

http://imageshack.us/f/97/exteriorlamps2.png/

This diagram shows that the rear spoiler is only illuminated with the Yellow/Grey wire, while the parking lights are Grey/Yellow. If they absolutely refuse to help you, go to a different dealer and try again. If nobody will help, try disconnecting each taillight and seeing if that fixed the issue. If you have a multimeter, check for voltage on each wire. With running lights on, you should only have power on the 'mostly grey with yellow stripe'

Last edited by ahanix1989; 12-15-2012 at 11:38 AM.
ahanix1989 is offline   Reply With Quote
Old 01-08-2013, 09:59 PM   #4
NYMERC
Bicycle Rider
 
Join Date: Sep 2012
Posts: 9
Default Led tail lights ng

Turns out that both sides LED tail lights were NG and replaced under warranty by dealer. Over $1,000 cost had it not been covered. That makes a battery, throttle body and two times transmission re-flash under warranty so far.
NYMERC is offline   Reply With Quote
Old 01-08-2013, 11:22 PM   #5
ahanix1989
Moderator
 
ahanix1989's Avatar
 
Join Date: Oct 2010
Location: Wisconsin, USA
Posts: 1,809
Send a message via ICQ to ahanix1989 Send a message via AIM to ahanix1989 Send a message via MSN to ahanix1989 Send a message via Yahoo to ahanix1989
Default

well, at least it was under warranty!
ahanix1989 is offline   Reply With Quote
Old 01-09-2013, 01:25 AM   #6
wireless
Le Mans: GT Class
 
wireless's Avatar
 
Join Date: Aug 2010
Location: Greenville, TX
Posts: 836
Default

Quote:
Originally Posted by NYMERC View Post
Turns out that both sides LED tail lights were NG and replaced under warranty by dealer. Over $1,000 cost had it not been covered. That makes a battery, throttle body and two times transmission re-flash under warranty so far.
I don't think that's bad unless it was a throttle body failing on the highway... you must have the 6F35 to get that many transmission issues. Mine is at 48k (almost 50k) and no problems yet! *fingers crossed*
__________________
I don't own a Fusion anymore. I drive a GTI.

'10 Sterling Grey Fusion SE 2.5L, EvoX-R retrofit
wireless is offline   Reply With Quote
Old 01-13-2013, 08:44 PM   #7
NYMERC
Bicycle Rider
 
Join Date: Sep 2012
Posts: 9
Default

Thanks everyone for your help on this, especially ahanix1989.
Yes, I have the 6F35 transmission on a 2010 Milan w/only 18K miles on it.
Regarding the tail lamps, the dealer first replaced the brake switch (by the brake pedal on the floor) which did not resolve the problem, then ran a trace for a short as suggested which did not resolve the problem and finally determined that both rear LED lamp assemblies were not good.

The day after I left the dealer with shiny new tail lights (last Tuesday) I began once again having perhaps throttle body issues. I will post this in the correct section shortly. Thanks again.
NYMERC is offline   Reply With Quote
Old 01-14-2013, 07:11 AM   #8
ahanix1989
Moderator
 
ahanix1989's Avatar
 
Join Date: Oct 2010
Location: Wisconsin, USA
Posts: 1,809
Send a message via ICQ to ahanix1989 Send a message via AIM to ahanix1989 Send a message via MSN to ahanix1989 Send a message via Yahoo to ahanix1989
Default

All this talk about 6F35 Milans with issues concerns me... mine's at 31K and no issues so far...
ahanix1989 is offline   Reply With Quote
Old 09-20-2013, 11:35 AM   #9
Cinder405
Moped Rider
 
Join Date: Dec 2012
Posts: 14
Default

I have a Mercury Milan 2010 Hybrid Model and have a tail light problem. The right side flashes on and off when I push the brake. I have already checked for loose wires. The turn signal bulb is good but I guess maybe I need a new LED tail light right? I don't have warranty so how much do you think this will cost me? Also where should I purchase the part at?
Cinder405 is offline   Reply With Quote
Old 09-20-2013, 06:56 PM   #10
ahanix1989
Moderator
 
ahanix1989's Avatar
 
Join Date: Oct 2010
Location: Wisconsin, USA
Posts: 1,809
Send a message via ICQ to ahanix1989 Send a message via AIM to ahanix1989 Send a message via MSN to ahanix1989 Send a message via Yahoo to ahanix1989
Default

Ford seems bad about this. I used to pass a Montego with similar problems
ahanix1989 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  FordFusionClub.com : The #1 Ford Fusion Forum > Technical / Model / Performance for the Fusion, Milan, Zephyr > Exterior Lighting

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2006-2011 Mercury Milan mudflap set (Original Ford/Mercury part) cobra jet FFC Buy / Sell 6 07-04-2011 12:50 AM
Mercury Milan V6 CAI manamazing V6 Engine Discussion 8 06-11-2009 05:28 PM
06 Mercury Milan ferendon I Just Got My Fusion, Milan, Zephyr or MKZ! 13 05-01-2009 07:01 PM
Need Help: HID kit for 07 Mercury Milan radiant2 Exterior Lighting 6 10-02-2007 01:29 PM


All times are GMT -4. The time now is 05:29 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.