Front Right Turn Signal Does Not Work When Headlights Are On - FordFusionClub.com : The #1 Ford Fusion Forum


FMVPerformance.com is the premier Ford Fusion Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools
Old 08-26-2010, 09:49 PM   #1
Cel
Bicycle Rider
 
Join Date: Aug 2010
Posts: 6
Default Front Right Turn Signal Does Not Work When Headlights Are On

Hello all,

Sorry for asking for help on the first post. I've been lurking here for a while and enjoy the forum. On to the problem: I have a 2006 Mercury Milan Limited. When I have my parking lights or headlights on, the front right turn signal will not work. It's ONLY the right side.

It will blink one time and then stay solid. The guage cluster message center will say to 'Check the RF Lamp' or something similar. The right rear turn signal will also blink fast. With the headlights or park lights off, EVERYTHING works fine. The turn signal at both the front and back will blink normally.

Any ideas on what could be causing this? I'm thinking it could be a wiring problem that developed all of a sudden. Thanks for your help.
Cel is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-27-2010, 07:13 AM   #2
mrkyle3
Short Track Racer
 
mrkyle3's Avatar
 
Join Date: Jul 2010
Location: Maryland
Posts: 220
Default Re: Front Right Turn Signal Does Not Work When Headlights Are On

It sounds like a fuse issue to me judging from the fact that your rear signal blinks too quickly. You may just need to replace a fuse.
__________________
2011 Subaru WRX
mrkyle3 is offline   Reply With Quote
Old 08-27-2010, 12:40 PM   #3
Cel
Bicycle Rider
 
Join Date: Aug 2010
Posts: 6
Default Re: Front Right Turn Signal Does Not Work When Headlights Are On

Thanks mykyle3, I will give that a try.
Cel is offline   Reply With Quote
Old 08-27-2010, 04:12 PM   #4
Gilbertsville PA
Short Track Racer
 
Join Date: Mar 2010
Location: PA
Posts: 169
Default Re: Front Right Turn Signal Does Not Work When Headlights Are On

The bulb filiments may be touching in the parking turnsignal bulb.
Gilbertsville PA is offline   Reply With Quote
Old 08-27-2010, 04:27 PM   #5
Cel
Bicycle Rider
 
Join Date: Aug 2010
Posts: 6
Default Re: Front Right Turn Signal Does Not Work When Headlights Are On

Okay, the fuses are fine. Gilbertsville PA~ I'm using LED bulbs that I ordered from autolumination for the turn signals. It's crazy, because they work perfectly fine when the headlights or parking lights are not on. I swapped the led bulbs and put the right on the left and the left on the right. The left front turn signal started acting up. So I'm thinking it could just be the bulb. BUT, yesterday I went to autozone and put in a regular bulb on the right side and it did the same thing with a regular bulb. Right turn signal worked absolutely fine with the headlights or park lights off but when with them on, the turn signal just stays solid.
Cel is offline   Reply With Quote
Old 08-27-2010, 08:16 PM   #6
Cel
Bicycle Rider
 
Join Date: Aug 2010
Posts: 6
Default Re: Front Right Turn Signal Does Not Work When Headlights Are On

Also, another strange thing. When I removed the fuse that runs the park lights/turn signals and side marker lights, the turn signals work JUST FINE with the headlights on or off. Of course the sidemarkers and park lights are not lit up with the headlights on because of the fuse being removed, but they light up and blink just fine when you use the turn signal indicator. What tha h**l? :shock:
Cel is offline   Reply With Quote
Old 08-28-2010, 04:51 PM   #7
S1ck
Short Track Racer
 
Join Date: Mar 2008
Location: Long Island NY
Posts: 156
Default Re: Front Right Turn Signal Does Not Work When Headlights Are On

Try swapping the fuse. Could just be a bad fuse. Sometimes the lead cracks where you cant see it and it cant hold the load from the flasher. Also, be sure the bulbs are connected in the right polarity, as ive had LED sidemarkers that would turn on whichever way they are inserted, but would start doing crazy things.
S1ck is offline   Reply With Quote
Old 08-28-2010, 11:25 PM   #8
seasonalskier
Senior Member
 
seasonalskier's Avatar
 
Join Date: Feb 2009
Location: Livonia, MI
Posts: 13,375
Send a message via AIM to seasonalskier Send a message via Yahoo to seasonalskier
Default Re: Front Right Turn Signal Does Not Work When Headlights Are On

Nothing is wrong with fuses or anything you need to add resistors to the system, right now your car is thinking there is a short circuit in the system because of the dropped resistance thanks to the new bulbs, mine did the same thing, give me a minute and I will tell you what resistor you need.
seasonalskier is offline   Reply With Quote
Old 08-28-2010, 11:35 PM   #9
seasonalskier
Senior Member
 
seasonalskier's Avatar
 
Join Date: Feb 2009
Location: Livonia, MI
Posts: 13,375
Send a message via AIM to seasonalskier Send a message via Yahoo to seasonalskier
Default Re: Front Right Turn Signal Does Not Work When Headlights Are On

Ok so you need 2 of the 6 ohm resistors on this page: http://autolumination.com/equalizers.htm
This will trick your SJB into thinking there is a conventional bulb in there instead of an LED bulb. Your having the EXACT same problem as I was having when I first got my LED turn signals even down to the passenger side not working and the drivers does.
seasonalskier is offline   Reply With Quote
Old 08-29-2010, 03:27 AM   #10
Cel
Bicycle Rider
 
Join Date: Aug 2010
Posts: 6
Default Re: Front Right Turn Signal Does Not Work When Headlights Are On

S1ck~I checked and they are placed in correctly. They won't even come on if they are in wrong. They've been working fine for months. This problem just developed all of a sudden.

Seasonalskier~Thing is, they've been working fine since February. This problem just started all of a sudden. I am using the third ones from the top on this page: http://autolumination.com/3157_3156.htm The super white ones. What would cause this to happen out of the blue?

By the way, I really appreciate all of your responses. This forum has some of the most helpful people I have ever run across, in person or internet.
Cel is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  FordFusionClub.com : The #1 Ford Fusion Forum > Technical / Model / Performance for the Fusion, Milan, Zephyr > Exterior Lighting

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -4. The time now is 04:23 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.